E: no se puede localizar el package git – Ubuntu en EC2

Me parece que puede haber un problema con los espejos Ubuntu EC2. Después de una nueva actualización de apt-get, estoy haciendo esto:

$ apt-get install -yq git E: Unable to locate package git 

Después de unos pocos apt-get 's, a menudo tendrá éxito.

Actualice apt-get packages apt-get , ejecute el siguiente command:

 $ apt-get update 

Los espejos todavía parecen estar rotos, pero pude solucionar el problema con un bucle tonto:

 # stupid loop to get around ubuntu package mirror problems for attempt in 1 2 3; do if [ ! -z "`which git`" ]; then break fi echo "Trying to install git, attempt $attempt" sudo apt-get update -yq --fix-missing sudo apt-get install -yq git done 

3 bashs suelen ser suficientes para encontrar un espejo que funcione.