Dependencias de Android Sweet Alert Dialog

Leí el tutorial de Sweet AlertDialog y he agregado dependencies a mi proyecto de esta manera:

  1. selecciona Build.Gradle (Module: app) y abre

  2. ve a esta linea:

    dependencies { compile fileTree(dir: 'libs', include: ['*.jar']) } 

    y cambiar a:

     dependencies { compile fileTree(dir: 'libs', include: ['*.jar']) compile 'cn.pedant.sweetalert:library:1.3' } 
  3. Ejecuta mi aplicación, pero obtengo este error:

     Error:A problem occurnetworking configuring project ':app'. > Could not resolve all dependencies for configuration ':app:_debugCompile'. > Could not find com.android.support:appcompat-v7:21.0.0. Searched in the following locations: https://jcenter.bintray.com/com/android/support/appcompat-v7/21.0.0/appcompat-v7-21.0.0.pom https://jcenter.bintray.com/com/android/support/appcompat-v7/21.0.0/appcompat-v7-21.0.0.jar file:/D:/sdk/ADT-Bundle-Windows-x86-20140702.Full_p30download.com/sdk/extras/android/m2repository/com/android/support/appcompat-v7/21.0.0/appcompat-v7-21.0.0.pom file:/D:/sdk/ADT-Bundle-Windows-x86-20140702.Full_p30download.com/sdk/extras/android/m2repository/com/android/support/appcompat-v7/21.0.0/appcompat-v7-21.0.0.jar file:/D:/sdk/ADT-Bundle-Windows-x86-20140702.Full_p30download.com/sdk/extras/google/m2repository/com/android/support/appcompat-v7/21.0.0/appcompat-v7-21.0.0.pom file:/D:/sdk/ADT-Bundle-Windows-x86-20140702.Full_p30download.com/sdk/extras/google/m2repository/com/android/support/appcompat-v7/21.0.0/appcompat-v7-21.0.0.jar Requinetworking by: MyApplication:app:unspecified > cn.pedant.sweetalert:library:1.3 > com.pnikosis:materialish-progress:1.0 

Y cuando agrego appcompat-v7-21.0.0.jar obtengo este error:

 Error:Failed to find: com.android.support:appcompat-v7:21.0.0 <a href="openFile">Open File</a><br><a href="open.dependency.in.project.structure">Open in Project Structure dialog</a> 

Primero quite appcompat-v7-21.0.0.jar, luego intente replace sus dependencies con lo siguiente:

 dependencies { compile fileTree(dir: 'libs', include: ['*.jar']) compile 'com.android.support:appcompat-v7:21.0.3' compile 'cn.pedant.sweetalert:library:1.3' } 

Si se trata de un caso de falta de biblioteca de soporte, creo que debe download el repository de soporte de Android desde el

Administrador de Android SDK-> SDK Tools-> Support Repository-> Android Support Repository.