¿Cuál es la versión mínima de git para ejecutar el compositor?

Tengo un website alojado y quiero usar compositor para resolver las dependencies de mi proyecto en producción. Pero cada vez que ejecuto la actualización del compositor obtengo este error:

$ [RuntimeException] Failed to execute git status --porcelain --untracked-files=no error: unknown option `porcelain' 

Llegué a la conclusión: la versión de git en el host es demasiado antigua y no se puede reconocer, la opción de --porcelain .

Entonces, necesito actualizar git en el host, pero ¿para qué versión? ¿Cuál es la versión mínima que puedo actualizar git para ejecutar el compositor sin ningún problema?

La opción --porcelain se ha agregado al git status de git en git 1.7.0-rc0, commit 6f15787 en septiembre de 2009.

Entonces necesitas al less un git 1.7+.