compositor: RuntimeException

Estoy tratando de instalar Typo3-Neos a través del compositor.

Yo sigo las instrucciones enumeradas:

  • curl -s https://getcomposer.org/installer | php (para download el compositor)
  • php composer.phar self-update (ya actualizado)
  • php composer.phar create-project -s beta typo3 / neos-base-distribution Neos-2.0 (intenta download Typo3-Neos)

Durante el último paso, aparece el siguiente post:

# php composer.phar create-project -s beta typo3/neos base-distribution Neos-2.0 Installing typo3/neos-base-distribution (2.0.0-beta2) - Installing typo3/neos-base-distribution (2.0.0-beta2) Cloning f344c0bdc9b2f83341f443c66d460204eaa0afd2 Created project in Neos-2.0 Loading composer repositories with package information Installing dependencies (including require-dev) - Installing composer/installers (v1.0.21) Loading from cache Class TYPO3\Flow\Composer\InstallerScripts is not autoloadable, can not call post-package-install script - Installing symfony/console (v2.7.0) Loading from cache Class TYPO3\Flow\Composer\InstallerScripts is not autoloadable, can not call post-package-install script - Installing symfony/dom-crawler (v2.5.12) Loading from cache Class TYPO3\Flow\Composer\InstallerScripts is not autoloadable, can not call post-package-install script - Installing symfony/yaml (v2.5.12) Loading from cache ... a few more Class TYPO3\Flow\Composer\InstallerScripts is not autoloadable, can not call post-package-install script - Installing doctrine/orm (v2.4.7) Loading from cache Class TYPO3\Flow\Composer\InstallerScripts is not autoloadable, can not call post-package-install script - Installing typo3/eel (3.0.0-beta3) Cloning 108cd4e87cbdfb1d797a513590a3a77466248f8f [RuntimeException] Failed to execute git checkout '108cd4e87cbdfb1d797a513590a3a77466248f8f' -- && git reset --hard '108cd4e87cbdfb1d797a513590a3a77466248f8f' -- fatal: Not a git repository (or any of the parent directories): .git 

En una input de blog, el autor describió la actualización de la versión de git de la máquina. Lo intenté. La versión actual de git es (gentoo linux – listdo con banderas de uso usado):

  dev-vcs/git-2.4.1::gentoo USE="blksha1 cgi curl gpg iconv nls pcre perl python threads webdav -cvs -doc -emacs -gnome-keyring -gtk -highlight -mediawiki (-ppcsha1) -subversion {-test} -tk -xinetd" PYTHON_TARGETS="python2_7" 0 KiB 

¿Cuál puede ser el motivo de RuntimeException? Un error dentro del compositor, neos o debido a la configuration local (php, git, …)?

¡Gracias por tu time!

https://github.com/composer/composer/issues/996 menciona una solución alternativa.

actualización del compositor –prefer-dist hizo el trabajo