Compositor package por twig

Tengo un repository symfony bifurcado en GitHub y envié un código a la twig 2.4 . ¿Cómo puedo hacer que Composer use esta twig específica?

composer.json:

"require" : { ... "symfony/symfony" : "dev-2.4" }, "repositories" : { "type" : "vcs", "url" : "https://github.com/tamirvs/symfony" } 

Pero obtengo The requested package symfony/symfony dev-2.4 could not be found . También probé 2.4-dev y 2.4 pero recibo el mismo error.

Toda la información que encontré en la web me llevó a lo que ya he intentado … alguna idea?

Tenga en count que al configurar la versión en 2.4. * Se tira del repository pero sin mis confirmaciones.

Creo que necesitarás usar 2.4.x-dev , como se describe en la documentation .

Por ejemplo, una twig 2.0 recibirá una versión 2.0.x-dev (el .x se agrega por razones técnicas, para asegurarse de que se reconozca como una twig, una twig 2.0.x también sería válida y se convertiría en 2.0.x. -dev también

Pruebe 2.5-dev.

Creo que la sucursal tiene ese número de versión.

EDITAR:

Eche un vistazo a https://github.com/tamirvs/symfony/blob/master/composer.json

 "extra": { "branch-alias": { "dev-master": "2.5-dev" } }