Compositor extraído de GitHub bifurcado con Autoload

Así que estoy tratando de usar Composer para instalar esta extensión php-ffmpeg aquí:

https://github.com/sharapov-outsource/php-ffmpeg-extensions

Pero requiere php-ffmpeg 0.6.1 y la versión más nueva de php-ffmpeg es 0.9.3 Entonces, ¿cómo puedo usar Composer para instalar esto y permitir la versión 0.9.3 del php-ffmpeg? ¿Tengo que bifurcarlo? Si es así, ¿cómo configuro mi file composer.json para extraer y configurar las classs correctas?

Para la installation del compositor,

1) agregar:

"require": { "sharapov/php-ffmpeg-extensions": "0.9.3" }, 

a su file composer.json y actualice sus dependencies.

 $ composer update 

2) O puede ejecutar desde shell:

 $ composer require sharapov/php-ffmpeg-extensions:0.9.3 

La versión a usar se puede definir de las siguientes maneras:

  • 1.2 Puede especificar la versión del package (por ejemplo, 0.9.3 o 0.6.1 )
  • El operador ^ (cursivo) significa cualquier versión sin ruptura / hasta que la principal (por ejemplo, ^1.2.3 es equivalente a >=1.2.3<2.0.0 )
  • El operador ~ (tilde) significa dígito aproximado / incremento a la derecha (por ejemplo, ~1.2 es equivalente a >=1.2<2.0.0 o ~1.2.3 es equivalente a >=1.2.3 <1.3.0 )
  • El operador * (estrella) significa que todas las versiones en este nivel (p 1.0.* Ej., 1.0.* Es el equivalente de >=1.0<1.1 )
  • El 1.0-2.0 es el equivalente de >=1.0.0<2.1

Para más información, busque un doc. De compositor https://getcomposer.org/doc/