Composer install \ update authentication errors

Cuando bash instalar la dependencia desde mi repository privado, aparece el siguiente error:

> /opt/lampp/bin/php /home/arthur/Sites/audio-video-caption.com/composer.phar install Loading composer repositories with package information Failed to clone the git@github.com:Djevil83/UserBundle.git repository, try running in interactive mode so that you can enter your GitHub cnetworkingentials [RuntimeException] Failed to execute git clone --mirror 'git@github.com:Djevil83/UserBundle.git' '/home/arthur/.cache/composer/vcs/git-github.com-Djevil83-UserBundle.git/' install [--prefer-source] [--prefer-dist] [--dry-run] [--dev] [--no-dev] [--no-plugins] [--no-custom-installers] [--no-autoloader] [--no-scripts] [--no-progress] [-v|vv|vvv|--verbose] [-o|--optimize-autoloader] [-a|--classmap-authoritative] [--ignore-platform-reqs] [--] [<packages>]... Process finished with exit code 1 at 15:40:11. Execution time: 1 874 ms. 

`

Aquí está mi composer.json :

 "repositories": [ { "type": "vcs", "url": "git@github.com:Djevil83/UserBundle.git" }, ] 

Estoy usando Debian 8 y Xampp con php 7.

No sé dónde está el error … ¡gracias por tu ayuda!

Primero, confirme que configuró el acceso al repository: https://help.github.com/articles/adding-collaborators-to-a-personal-repository/ para que pueda clonarlo usando su key privada. El command:

 git clone git@github.com:Djevil83/UserBundle.git 

debería crear un nuevo directory UserBundle sin pedir contraseña.

Luego, lea https://getcomposer.org/doc/articles/troubleshooting.md#api-rate-limit-and-oauth-tokens cómo configurar el token OAuth para boost el límite de velocidad.

No hay ningún repository UserBundle , consulte https://github.com/Djevil83?tab=repositories . Tal vez el UtilitiesBundle es el adecuado. Intenta cambiar la línea a

"url": "git@github.com:Djevil83/UtilitiesBundle.git

en tu composer.json .