CocoaPods: apunta a una twig en la especificación del pod

Intento instalar el código de la twig de un repository en una especificación de pod, y según la documentation, esto debería funcionar:

s.dependency 'repository_name', :git => 'https://github.com/account_name/repository_name.git', :branch => 'experimental_branch' 

Pero me sale un error con algo así como [!] Requisitos de versión incompatibles. La actualización de CocoaPods podría solucionar el problema.

Funciona al instalar desde un file pod directamente:

 pod 'ObjectiveRecord', :git => 'https://github.com/supermarin/ObjectiveRecord.git', :branch => '2-0-experimental' 

¿Alguien sabe? ¡Gracias!

No puede usar una dependencia de pod como esa, solo admite "name", "version" . Fuente: guides.cocoapods.org . Se espera que los metadatos :git y :branch provengan del file podfile.