¿Cómo renovar el cliente de git en Ubuntu?

Cada vez que uso el command git , aparece esta advertencia:

Tu versión de git es 1.9.1. Que tiene serias vulnerabilidades de security. Más información aquí: https://blog.heroku.com/archives/2014/12/23/update_your_git_clients_on_windows_and_os_x

Pero tengo Ubuntu. He intentado ejecutar sudo apt-get update y luego sudo apt-get upgrade , pero no renueva la versión del cliente de git.

 sudo add-apt-repository ppa:git-core/ppa sudo apt-get update sudo apt-get install git