Cómo instalar git 1.8 o superior en Debian Wheezy

Intento tratar de instalar una versión posterior de git (principalmente 1.8. * O superior). si bash instalarlo usando apt-get install git , termino instalando la versión 1.7.10.4 .

Ya he intentado cambiar el repository usando el siguiente método:

 add-apt-repository ppa:git-core/ppa apt-get update apt-get install git 

El resultado de la apt-get update de apt-get update me da lo siguiente y debido a eso, termino instalando la versión 1.7.10.4 nuevamente.

 W: Failed to fetch http://ppa.launchpad.net/git-core/ppa/ubuntu/dists/wheezy/main/source/Sources 404 Not Found W: Failed to fetch http://ppa.launchpad.net/git-core/ppa/ubuntu/dists/wheezy/main/binary-amd64/Packages 404 Not Found 

También traté de instalar git usando un backport, como el siguiente:

 sudo apt-get install git/wheezy-backports sudo apt-get -t wheezy-backports install git 

Nunca termino más allá de apt-get install git/wheezy-backports porque luego termino recibiendo el siguiente error:

 E: Release 'wheezy-backports' for 'git' was not found 

¿Cómo instalaría git 1.8. * O superior en Debian Wheezy?

Definitivamente recomendaría usar la versión de backports. Para usar el repository de backports, tenga en count que debe agregar la siguiente línea a su /etc/apt/sources.list:

 deb http://http.debian.net/debian wheezy-backports main 

Y luego puedes volver a intentarlo con apt-get. Encontrará instrucciones completas en http://backports.debian.org/Instructions/#index2h2

Permítanme proporcionar una solución limpia de copyr y pegar:

 echo "deb http://http.debian.net/debian wheezy-backports main" >/etc/apt/sources.list.d/wheezy-backports.list sudo apt-get update -qq sudo apt-get -t wheezy-backports install -y -qq git mercurial 

Clonar desde su repository https://github.com/git/git y comstackrlo usted mismo. Lo hice en Cygwin y fue fácil, así que debería estar bien en Debian. Lea el file INSTALL, es bastante autoexplicativo.

Si no ha comstackdo el software antes, debe saber que se requieren bastantes requisitos previos (se incluyen en la INSTALACIÓN). Deberías ser capaz apt-get .