Cómo establecer el origen (enlace git) para la dependencia del cocoapod

Bifurqué Amazon SDK para alterar algunos comportamientos y usarlo a través de cocoapods. En podfile se ve como

pod 'AWSiOSSDKv2', :git => "https://github.com/vGubriienko/aws-sdk-ios.git", :tag => '2.2.2.BT', :inhibit_warnings => true 

Lamentablemente, en los últimos lanzamientos pasaron de la idea de un pod al pod de raíz + subespec para cada uno de sus services. Y cuando instalé la versión actualizada la primera vez, descubrí que el pod actualizado usa subpods realmente no actualizados (como la versión 2.2.2 en lugar de la versión 2.2.2.BT).

La investigación mostró que también necesito actualizar todas las podspecs alteradas. Y hay un problema AWSS3 podspec tiene una dependencia:

 s.dependency 'AWSCore' 

Pero esta dependencia mira el pod original en lugar de mi fork alterado. Traté de usar algo como:

 s.dependency 'AWSCore', :git => 'https://github.com/vGubriienko/aws-sdk-ios.git', :tag => '2.2.2.BT' 

Pero los cocoapods no pudieron instalar el pod en este caso.