CCNet dispara la construcción, pero tiene éxito incluso si controlo el código incorrecto a svn

He configurado CruiseControl para .NET con SVN como mi control de fuente y uso el script de compilation NAnt. Cuando construyo manualmente la solución visual studio obtengo errores, lo cual es correcto porque tengo un código incorrecto. Después de que ingresé el código a svn, CCNet activó la compilation, pero el resultado se muestra como SUCCESS. Por favor, vea los files de configuration y compilation a continuación:

Archivo de compilation NAnt:

<project name="MyServiceClient" default="build"> <target name="init" depends="clean" /> <target name="clean" /> <target name="checkout"/> <target name="compile"/> <!--<target name="deploy"/> <target name="test"/> <target name="inspect"/>--> <target name="build" depends="init, checkout"> <call target="compile" /> <!-- <call target="inspect" /> <call target="test" /> <call target="deploy" />--> </target> </project> 

ccnet.config

 <cruisecontrol> <project name="MyServiceClient"> <sourcecontrol type="svn"> <trunkUrl>https://dev-wks28.dev.va.root:8443/svn/test/trunk/MyServiceClient</trunkUrl> <executable>C:/Program Files/VisualSVN Server/bin/svn.exe</executable> <workingDirectory>C:\test\MyServiceClient</workingDirectory> <username>kpedda</username> <password>Password1</password> <autoGetSource>true</autoGetSource> </sourcecontrol> <workingDirectory>C:\test\MyServiceClient</workingDirectory> <triggers> <intervalTrigger seconds="90" buildCondition="IfModificationExists" /> <scheduleTrigger time="10:00" buildCondition="ForceBuild" /> </triggers> <tasks> <nant> <executable>C:/Program Files/NAnt/bin/nant.exe</executable> <baseDirectory>C:/Apps</baseDirectory> <!--<workingDirectory>C:/test/MyServiceClient</workingDirectory>--> <!--<projectFile>MyServiceClient.sln</projectFile>--> <buildFile>default.build</buildFile> <targetList> <target>build</target> </targetList> </nant> </tasks> <publishers> <xmllogger/> </publishers> 

¿Alguien puede decirme qué está pasando?

Tu NANT pegado nuevamente:

 <?xml version="1.0"?> <project name="MyServiceClient" default="build"> <target name="init" depends="clean" /> <target name="clean" /> <target name="checkout"/> <target name="compile"/> <!--<target name="deploy"/> <target name="test"/> <target name="inspect"/>--> <target name="build" depends="init, checkout"> <call target="compile" /> <!-- <call target="inspect" /> <call target="test" /> <call target="deploy" />--> </target> </project> 

Este script no hace nada. NANT ni siquiera mira tu código fuente con este script.