Bloqueado pom.xml provoca error de comprobación de la twig de git en eclipse

Estoy usando Eclipse con Egit / Github y Maven en Windows. A menudo, pero no siempre, al revisar una sucursal, se genera un post de error que indica que el file pom.xml no se pudo renombrar, lo que hace que el process de pago falle. El file está bloqueado por Windows, lo que impide el cambio de nombre. Usando Handle como se sugiere a continuación, se muestra que Eclipse tiene el candado. Los colegas no ven este problema. Instalé una instancia completamente diferente de Eclipse y cloné el repository en una location diferente y obtuve los mismos resultados.

Todo esto causa un gran lío en mi repository porque Git no tiene una function de reversión en la falla de pago. Se copyron todos los files de la twig de ir a la input, pero git mantiene la twig de salida de check-in desprotegida. Todos los files que difieren entre las twigs se muestran como modificados. La limpieza requiere un poco de trabajo.

En la niebla de los complementos de eclipse, no pude encontrar la respuesta exacta, pero esta era la solución.

El problema estaba en los complementos de IBM Websphere y Bluemix. Hay varias opciones para instalar esos complementos que dan como resultado contenido diferente.

Desde el Eclipse Marketplace:

  • El set defectuoso provino de Eclipse Marketplace de "IBM Liberty Developer Tools for Oxygen"
  • El set bueno vino de "IBM Eclipse Tools for Bluemix Oxygen"

Los plug-ins problemáticos son estos:

IBM Bluemix Tools 1.0.2.v20171004_2101 com.ibm.wdt.bluemixtools.feature.feature.group IBM OSGi Application Development Tools 17.0.3000.v20171004_2101 com.ibm.osgi.wdt.feature.feature.group IBM Web Development Tools 17.0.3000.v20171004_2101 com.ibm.wdt.webtools.top.feature.feature.group IBM Web Services Development Tools 17.0.3000.v20171004_2101 com.ibm.wdt.ast.ws.tools.feature.feature.group IBM 

Los que funcionan son estos:

 IBM Bluemix Tools 17.0.3000.v20171004_2330 com.ibm.cftools.ext.feature.feature.group IBM WebSphere® Application Server Liberty Tools 1.0.2.v20171004_2330 com.ibm.cftools.server.tools.feature.feature.group IBM 

Estos dos vienen con cualquier package, pero son necesarios en una installation websphere / bluemix.

 Cloud Foundry Tools Core 1.2.3.v201709130027 org.eclipse.cft.server.core.feature.feature.group Eclipse Tools for Cloud Foundry Cloud Foundry Tools UI 1.0.10.v201709130027 org.eclipse.cft.server.ui.feature.feature.group Eclipse Tools for Cloud Foundry 

Al escribir estas líneas, este enlace tiene la información actual sobre la installation de Bluemix / Websphere: https://console.bluemix.net/docs/manageapps/eclipsetools/eclipsetools.html#eclipsetools