Angular 2, installation de la biblioteca del repository de Github

Estoy aprendiendo a crear una biblioteca de Angular 2 basada en un proyecto creado con Angular-CLI. Voy por estos ejemplos ng-demo-lib y ng-demo-app de Nikita Smolenskii.

La dependencia de la biblioteca se enumera de esta manera en package.json:

"ng-demo-lib": "git+ssh://git@github.com/nsmolenskii/ng-demo-lib.git", 

El problema es que cuando ejecuto npm install en ng-demo-app obtengo:

 npm ERR! git clone --template=/Users/xxx/.npm/_git-remotes/_templates --mirror ssh://git@github.com/nsmolenskii/ng-demo-lib.git /Users/xxx/.npm/_git-remotes/git-ssh-git-github-com-nsmolenskii-ng-demo-lib-git-ea5cc26b: Cloning into bare repository '/Users/xxx/.npm/_git-remotes/git-ssh-git-github-com-nsmolenskii-ng-demo-lib-git-ea5cc26b'... npm ERR! git clone --template=/Users/xxx/.npm/_git-remotes/_templates --mirror ssh://git@github.com/nsmolenskii/ng-demo-lib.git /Users/xxx/.npm/_git-remotes/git-ssh-git-github-com-nsmolenskii-ng-demo-lib-git-ea5cc26b: Permission denied (publickey). npm ERR! git clone --template=/Users/xxx/.npm/_git-remotes/_templates --mirror ssh://git@github.com/nsmolenskii/ng-demo-lib.git /Users/xxx/.npm/_git-remotes/git-ssh-git-github-com-nsmolenskii-ng-demo-lib-git-ea5cc26b: fatal: Could not read from remote repository. npm ERR! git clone --template=/Users/xxx/.npm/_git-remotes/_templates --mirror ssh://git@github.com/nsmolenskii/ng-demo-lib.git /Users/xxx/.npm/_git-remotes/git-ssh-git-github-com-nsmolenskii-ng-demo-lib-git-ea5cc26b: npm ERR! git clone --template=/Users/xxx/.npm/_git-remotes/_templates --mirror ssh://git@github.com/nsmolenskii/ng-demo-lib.git /Users/xxx/.npm/_git-remotes/git-ssh-git-github-com-nsmolenskii-ng-demo-lib-git-ea5cc26b: Please make sure you have the correct access rights npm ERR! git clone --template=/Users/xxx/.npm/_git-remotes/_templates --mirror ssh://git@github.com/nsmolenskii/ng-demo-lib.git /Users/xxx/.npm/_git-remotes/git-ssh-git-github-com-nsmolenskii-ng-demo-lib-git-ea5cc26b: and the repository exists. npm ERR! Darwin 16.4.0 npm ERR! argv "/usr/local/bin/node" "/usr/local/bin/npm" "install" npm ERR! node v7.5.0 npm ERR! npm v4.1.2 npm ERR! code 128 npm ERR! Command failed: git clone --template=/Users/xxx/.npm/_git-remotes/_templates --mirror ssh://git@github.com/nsmolenskii/ng-demo-lib.git /Users/xxx/.npm/_git-remotes/git-ssh-git-github-com-nsmolenskii-ng-demo-lib-git-ea5cc26b npm ERR! Cloning into bare repository '/Users/xxx/.npm/_git-remotes/git-ssh-git-github-com-nsmolenskii-ng-demo-lib-git-ea5cc26b'... npm ERR! Permission denied (publickey). npm ERR! fatal: Could not read from remote repository. npm ERR! npm ERR! Please make sure you have the correct access rights npm ERR! and the repository exists. npm ERR! npm ERR! npm ERR! If you need help, you may report this error at: npm ERR! <https://github.com/npm/npm/issues> npm ERR! Please include the following file with any support request: npm ERR! /Users/xxx/Desktop/nsmolenskii/ng-demo-app/npm-debug.log 

Nunca he tratado de importar desde un repository remoto en el package.json. Esto es nuevo para mi. ¿Hay algo que deba configurar para que Github conozca mi identidad? ¿Cómo soluciono este problema de permissions?

intente instalar form github como este npm i -D github:user-name/repo-name , o defina así en su file package.json:

 { "dependencies": { "repo-name": "github:user-name/repo-name" } } 

luego ejecuta la npm install