Android Studio: no se pudo resolver la <dependencia Github>

Permítanme comenzar diciendo que recientemente migré a Android Studio y, para ser totalmente honesto, no me gustó. Ahora está tratando de importar este git en mi proyecto: https://github.com/ongakuer/CircleIndicator. Aunque el enunciado de compilation que el propietario solicitó poner crea el error. Lo agregué a la dependencia {} en mi file build.gradle.

compile 'me.relex:circleindicator:1.1.5@aar' 

Error al resolver: me.relex: circleindicator: 1.1.5@aar

Probablemente has olvidado esta línea debajo de tu gradle:

 allprojects { repositories { jcenter() } } 

Edite el root gradle ubicado en root / build.gradle

Voy a explicar un poco:

Cuando agrega esta línea: comstack 'repository o jar url', le pide a su gradle que encuentre el repository (o el contenedor) y lo agregue a su fuente.

Pero, ¿dónde debería search este repository en particular? Ese es el propósito de esta línea, declarar una location desde donde debe search el gradle. En la mayoría de los casos, es – jcenter ( ver este enlace )

Simplemente abra build.gradle (Módulo: aplicación) y copie pase en sus dependencies

 dependencies { compile 'me.relex:circleindicator:1.1.5@aar' }