Android: no se pudo resolver la dependencia en el estudio Android

Estoy usando Android Studio 1.4 y estoy desarrollando aplicaciones donde necesito almacenar datos en Couchbase Lite. Estoy agregando la dependencia de la siguiente manera en el nivel de la aplicación compilation build.gradle 'com.couchbase.lite: couchbase-lite-android: 1.0.2'

apply plugin: 'com.android.application' android { compileSdkVersion 23 buildToolsVersion "23.0.1" packagingOptions { exclude 'META-INF/ASL2.0' exclude 'META-INF/LICENSE' exclude 'META-INF/NOTICE' } defaultConfig { applicationId "com.couchbase.examples.couchdb" minSdkVersion 15 targetSdkVersion 23 versionCode 1 versionName "1.0" } buildTypes { release { minifyEnabled false proguardFiles getDefaultProguardFile('proguard-android.txt'), 'proguard-rules.pro' } } } dependencies { compile fileTree(dir: 'libs', include: ['*.jar']) testCompile 'junit:junit:4.12' compile 'com.android.support:appcompat-v7:23.0.1' compile 'com.android.support:design:23.0.1' compile 'com.couchbase.lite:couchbase-lite-android:1.0.2' } 

y el código de abajo es de otra build.grade donde he agregado el siguiente código:

  repositories { jcenter() maven { url "http://files.couchbase.com/maven2/" } 

Pero el problema es que recibo un error cuando hago clic en "Sync project with gradle file option" en android studio. El error es:

 Failed to resolve:com.couchbase.lite:couchbase-lite-android:1.0.2 

Error al resolver: com.couchbase.lite: couchbase-lite-android: 1.0.2

Este problema sucede porque

 compile 'com.couchbase.lite:couchbase-lite-android:1.0.2' 

no existe en jcenter repo.
Puedes consultar este enlace .

Actualmente la única versión es 1.1.0.

Solo usa:

 compile 'com.couchbase.lite:couchbase-lite-android:1.1.0' 

He instalado correctamente lib de couchbase siguiendo los siguientes pasos:

  1. Elimine la línea de repository adicional (el código de maven), esto significa que su código de repository debe ser como:

     repositories { jcenter() } 
  2. Cambie su línea de compilation de sofá en este:

     compile 'com.couchbase.lite:couchbase-lite-android:1.+' 

Le dice a gradle (la cosa '. +') Que siempre tome la última versión.

Espero que te ayude