Agregar module de GIT a Android Studio arroja el error "buildToolsVersion no se especifica"

Quiero include este Selector de color en mi proyecto de Android Studio.

Así que lo revisé en una carpeta local y lo agregué a mi proyecto con el cuadro de dialog "Nuevo-> Importar module en Android Studio".

Luego agregué esas 2 líneas a mi file app.gradle

apply plugin: 'com.android.application' ... compile project(':colorpicker') 

Aquí está el file gradle completo

 apply plugin: 'com.android.application' android { compileSdkVersion 24 buildToolsVersion '24.0.2' defaultConfig { applicationId "com.mydomain.myapp" minSdkVersion 17 targetSdkVersion 24 } buildTypes { release { minifyEnabled false proguardFiles getDefaultProguardFile('proguard-android.txt'), 'proguard-rules.pro' } } } repositories { maven { url "https://jitpack.io" } } dependencies { compile fileTree(include: ['*.jar'], dir: 'libs') testCompile 'junit:junit:4.12' compile fileTree(include: ['dtp_library'], dir: 'libs') compile project(':libs:dtp_library') compile 'com.android.support:design:24.2.1' compile project(':colorpicker') } 

Pero sigo recibiendo el error

Error: Causa: buildToolsVersion no está especificado.

Si no agrego la primera línea al file gradle (hazlo exactamente como decía la descripción del selector de color), entonces obtengo

Error: (3, 0) No se pudo encontrar el método android () para los arguments [build_xxxxx] en el proyecto ': app' del tipo org.gradle.api.Project.

¿Como arreglarlo?

Sigue los pasos :

Abra el file build.gradle del module selector de color

enter image description here

entonces en su caso agregue estas líneas al file colorpicker module colorpicker

 compileSdkVersion 24 buildToolsVersion '24.0.2' 

Por favor ponga su buildToolVersion entre comillas dobles como

 buildToolsVersion "23.0.2"