SVN cómo mejora la copy de trabajo

Yo uso STS para trabajar con SVN. Cuando bash actualizar (versión 1.6) recibí este error:

org.apache.subversion.javahl.ClientException: Invalid operation on the current working directory svn: Can't upgrade 'C:\..... as it is not a pre-1.7 working copy directory 

No se puede encontrar una input. Svn: Falta la input pnetworkingeterminada. Pero estoy seguro de que no la he encontrado. Tengo una nueva carpeta. ¿Cómo se puede resolver? Gracias.

Intenta actualizar la copy de trabajo 1.7 (WC-NG). Pero la actualización solo fue necesaria una vez para 1.6 WC

Sé que esta pregunta es bastante antigua, pero para las personas que se tropiezan con ella como yo y todavía tienen problemas, hay una gotchya de la que deben tenerse en count: este command fallará si no se ejecuta desde la raíz de la copy de trabajo . En mi caso, estaba en una subcarpeta y recibí el post de error:

 svn: E155019: Can't upgrade '<path_to_sub_folder>' as it is not a pre-1.7 working copy root, the root is '<my_working_copy_root>' 

Simplemente cambie a la raíz de la copy de trabajo y emita la información previamente mencionada

 svn upgrade 

Todo debería estar bien, entonces.

Probablemente actualizar tu proyecto a 1.7 no funcionó … allí estarás en un gran problema ya que svn1.7 no manejará 1.6 proyectos (increíble pero verdadero oO)

Intente los siguientes commands desde la línea de command

 cd <working copy> svn upgrade 

Su copy de trabajo interna no cumple con la versión 1.7

Lea atentamente el post de error, ya que contiene el nombre de una subcarpeta en su copy de trabajo que no se ha actualizado para el uso de 1.7. De ahora en adelante, actualice esa carpeta específica:

 svn upgrade ./[folder name] 

(o cualquier command que use su cliente SVN)