Problemas para actualizar desde Symfony 2.3 a 2.4

Hola, tengo un problema realmente serio y no lógico. Estoy tratando de actualizar mi proyecto de Symfony2.3 a la versión 2.4, pero después de ejecutar la actualización del compositor todo está bien, pero al igual que el proyecto es con más personas y está en un server SVN cuando alguien más descarga el proyecto esto no funciona y en el momento en que ejecutó la actualización del compositor, esto vuelve a 2.3. *;

aquí está mi compositor.json:

{ "name": "symfony/framework-standard-edition", "license": "MIT", "type": "project", "description": "The \"Symfony Standard Edition\" distribution", "autoload": { "psr-0": {"": "src/"} }, "require": { "php": ">=5.3.3", "symfony/symfony": "2.4.*", "doctrine/orm": ">=2.2.3,<2.4-dev", "doctrine/doctrine-bundle": "1.2.*", "twig/extensions": "1.0.*", "symfony/assetic-bundle": "2.3.*", "symfony/swiftmailer-bundle": "2.3.*", "symfony/monolog-bundle": "2.3.*", "sensio/distribution-bundle": "2.3.*", "sensio/framework-extra-bundle": "2.3.*", "sensio/generator-bundle": "2.3.*", "incenteev/composer-parameter-handler": "~2.0", "cedriclombardot/admingenerator-generator-bundle": "2.3.*@dev", "propel/propel-bundle": "1.2.*", "educoder/pest": "1.0.0", "friendsofsymfony/rest-bundle": "0.12.0", "jms/serializer-bundle": "dev-master", "jms/di-extra-bundle": "dev-master", "phpexcel/phpexcel": "1.7.*", "laurentbrieu/tcpdf": "dev-master" }, "scripts": { "post-install-cmd": [ "Incenteev\\ParameterHandler\\ScriptHandler::buildParameters", "Sensio\\Bundle\\DistributionBundle\\Composer\\ScriptHandler::buildBootstrap", "Sensio\\Bundle\\DistributionBundle\\Composer\\ScriptHandler::clearCache", "Sensio\\Bundle\\DistributionBundle\\Composer\\ScriptHandler::installAssets", "Sensio\\Bundle\\DistributionBundle\\Composer\\ScriptHandler::installRequirementsFile" ], "post-update-cmd": [ "Incenteev\\ParameterHandler\\ScriptHandler::buildParameters", "Sensio\\Bundle\\DistributionBundle\\Composer\\ScriptHandler::buildBootstrap", "Sensio\\Bundle\\DistributionBundle\\Composer\\ScriptHandler::clearCache", "Sensio\\Bundle\\DistributionBundle\\Composer\\ScriptHandler::installAssets", "Sensio\\Bundle\\DistributionBundle\\Composer\\ScriptHandler::installRequirementsFile" ] }, "config": { "bin-dir": "bin", "component-dir": "web/components" }, "minimum-stability": "dev", "extra": { "symfony-app-dir": "app", "symfony-web-dir": "web", "incenteev-parameters": { "file": "app/config/parameters.yml" }, "branch-alias": { "dev-master": "2.3-dev" } } } 

Lo resolví usando exactamente Symfony 2.4.1, estábamos usando Symfony 2.4.2-DEV, no sé, supongo que todavía hay un error en esta versión.