Git Error al intentar cambiar el editor central

Cometí un error al configurar mi editor principal ahora no puedo cambiarlo … intenté que cambiara a TextMate y lo cambie correctamente a sublime, pero sigo recibiendo el mismo error que el que se ve a continuación … ¿Cómo puedo solucionarlo? ¿esta? Realmente solo quiero que mi editor central sea TextMate.

Ryans-MacBook-Pro:~ RFreude$ git config --global core.editor "subl -n -w" Ryans-MacBook-Pro:~ RFreude$ git config --global -e 

text sublime 3 -w: sublime: command no encontrado

error: Hubo un problema con el editor 'sublime text 3 -w' ".

¡Gracias!

Como dijiste que el enlace está roto, puedes intentar crear el enlace simbólico nuevamente usando:

 ln -s "/Applications/Sublime Text.app/Contents/ShanetworkingSupport/bin/subl" /usr/local/bin/subl 

Más detalles aquí

Es posible que desee revertir esa edición usando

 ➜ git config --global core.editor "vim" 

y verificar si eso funciona bien

 ➜ git config --global --edit