Etiquetar las actualizaciones del package del compositor

Tengo un package de compositor PHP que requiere "illuminate/support":"4.1.*" Para usar con la integración de Laravel 4.1. Tengo un nuevo proyecto de Laravel que ahora está en v 4.2. *. Creo que ahora necesito actualizar el package para requerir "illuminate/support":"4.2.*" (Debido a errores del compositor). ¿Cuál es la mejor manera de mantener el soporte para Laravel v4.1 y v4.2 en el package?

Aquí está el file composer.json mi package de composer.json :

 { "name": "appointedd/appointedd-php", "description": "", "authors": [ { "name": "Billy Jones", "email": "billy@appointedd.com" } ], "require": { "php": ">=5.3.0", "illuminate/support": "4.1.*", "guzzlehttp/guzzle": "~4.0" }, "autoload": { "psr-0": { "Appointedd\\Appointedd": "src/" } }, "minimum-stability": "stable" } 

Actualmente está labeldo en la versión 0.0.3 . ¿Debo actualizar el file composer.json para requerir 4.2. * Y labelrlo 0.1.0 o usar un nombre más significativo?

La pregunta es qué diferencias están entre 4.1 y 4.2 que necesita para soportarlo de manera diferente. La versión semántica debería garantizar que la versión menor más nueva solo presente características compatibles con BC y correcciones de errores.

En cuanto a su pregunta, puede include el range de versión en su file composer.json , como se describe aquí :

Rango> = 1.0> = 1.0, <2.0> = 1.0, <1.1 | > = 1.2 Al usar operadores de comparación, puede especificar ranges de versiones válidas. Los operadores válidos son>,> =, <, <=,! =. Puede definir múltiples ranges, separados por una coma, que se tratarán como AND lógico. Un símbolo de tubería | será tratado como un OR lógico. Y tiene mayor prioridad que OR.

En su situación, sería algo así como:

 "illuminate/support": ">=4.1.0,<4.3",