error: el conector Mylyn GitHub no se instala en eclipse juno

instalé el plugin de EGit para eclipse con éxito pero el conector de Mylyn GitHub no se está instalando en eclipse. Aquí estoy agregando los detalles del error

Cannot complete the install because one or more requinetworking items could not be found. Software being installed: Eclipse EGit Mylyn GitHub Feature 2.3.0.201302130906 (org.eclipse.mylyn.github.feature.feature.group 2.3.0.201302130906) Missing requirement: Mylyn GitHub Connector UI 2.3.0.201302130906 (org.eclipse.mylyn.github.ui 2.3.0.201302130906) requires 'package org.eclipse.egit.core [2.3.0,2.4.0)' but it could not be found Cannot satisfy dependency: From: Eclipse EGit Mylyn GitHub Feature 2.3.0.201302130906 (org.eclipse.mylyn.github.feature.feature.group 2.3.0.201302130906) To: org.eclipse.mylyn.github.ui [2.3.0.201302130906] 

Eso sucede si tu versión de eclipse es demasiado antigua, como se detalla en el error 365425

Asegúrese de que su Eclipse sea al less 3.7 o más reciente.

La última versión de EGit 3.0.x requeriría un Eclipse Kepler 4.3.

Me sucedió ayer porque faltaba GitHub Mylyn Connector ( http://download.eclipse.org/egit/github/updates ) en Eclipse Window / Preferences / Install / Update / Available Software Sites y Eclipse intentó recuperar la versión obsoleta 2.3. 0 de otro http://download.eclipse.org/ ??? sitio de software (no recuerdo exactamente), incluyendo org.eclipse.mylyn.github.ui [2.3.0.201302130906] mientras que ya había una versión preinstalada de 3.0.3.alguno en Juno. Agregar el sitio de software faltante me permitió instalar la versión 3.0.3 …