Compositor entra en conflicto con la label GitHub con su hash de confirmación

Cuando ejecuto la composer update con muchos packages obtengo este error:

 Problem 1 - Installation request for piwik/piwik dev-2491e6bfcf61984b0f0f3387e1496815e809c6cc -> satisfiable by piwik/piwik[dev-2491e6bfcf61984b0f0f3387e1496815e809c6cc]. - myspace/MyPlugin 2.13.0 requires piwik/piwik >=2.16.0 -> satisfiable by piwik/piwik[2.16.0]. - Can only install one of: piwik/piwik[2.16.0, dev-2491e6bfcf61984b0f0f3387e1496815e809c6cc]. - Installation request for myspace/myplugin 2.13.0 -> satisfiable by myspace/MyPlugin[2.13.0]. 

Lo extraño es que la label 2.16.0 es exactamente la misma confirmación que dev-2491e6bfcf61984b0f0f3387e1496815e809c6cc . Además, no veo ningún composer.json dependiente que requiera dev-2491e6bfcf61984b0f0f3387e1496815e809c6cc .

Esto en mi composer.json principal.json. Los repositorys se definen como ( https://github.com/myspace/MyPlugin.git es una dirección falsa):

 "repositories": { "myspace-myplugin": { "type": "vcs", "url": "https://github.com/myspace/MyPlugin.git" }, "require": { "myspace/MyPlugin": "2.13.0" } } 

y requisitos de composer.json dependientes de myspace/MyPlugin :

 "require": { "piwik/piwik": ">=2.16.0", "php": ">=5.4" } 

>=2.16.0 restricción de la versión ilimitada >=2.16.0 al range ^2.16 en piwik/piwik – esto instalará piwik/piwik (2.16.1-b1) atm.

También agregué beta minimum-stability porque piwik 2.16.0 tiene una dependencia en php-di 5.0.0-beta , que no se pudo resolver con el nivel de estabilidad dado. Necesitamos bajar para get material beta. Y probablemente deberían elevarlo a una versión estable de su lado.

En resumen: intente con el siguiente composer.json .

 { "require": { "piwik/piwik": "^2.16", "php": ">=5.4" }, "minimum-stability": "beta" } 

Probado y funciona para mí.