Composer falla al instalar una dependencia de una dependencia

Este es mi compositor.json de root

{ "name": "roots/bedrock", "type": "project", "license": "MIT", "description": "A modern WordPress stack", "config": { "prefernetworking-install": "dist", "secure-http": false }, "minimum-stability": "dev", "repositories": [{ "type": "composer", "url": "https://wpackagist.org" }, { "name": "theme/website", "type": "vcs", "url": "git@git.mikgit.it:themes/theme-main.git", "component-type": "wordpress-theme" },], "require": { "php": ">=5.4", "composer/installers": "~1.0.12", "vlucas/phpdotenv": "^2.0.1", "johnpbloch/wordpress": "4.7.3", "oscarotero/env": "^1.0", "roots/soil": "3.6.2", "theme/website": "2.0.4", }, "extra": { "installer-paths": { "web/app/mu-plugins/{$name}/": ["type:wordpress-muplugin"], "web/app/plugins/{$name}/": ["component-type:wordpress-plugin"], "web/app/themes/{$name}/": ["component-type:wordpress-theme"] }, "wordpress-install-dir": "web/wp" }, "require-dev": { "lucatume/wp-browser": "^1.19" } } 

Este es el compositor.json de mi tema

 { "name": "theme/website", "description": "WP Theme builder", "license":"MIT", "type": "wordpress-theme", "repositories": [{ "name": "myFramework", "type": "vcs", "url": "git@git.mikgit.it:dip/myFramework.git", "component-type": "theme-autoload" }, { "name": "myEmbed", "type": "vcs", "url": "git@git.mikgit.it:dip/empedPosts.git", "component-type": "theme-autoload" }], "require": { "myFramework": "2.1.3", "myEmbed": "1.8.3" }, "extra": { "installer-paths": { "theme-autoload/{$name}/": ["type:theme-autoload", "component-type:theme-autoload"] } } } 

Ovviously myFramework y myEmbed están labeldos correctamente.

 { "name": "myFramework", "description": "Framework Theme", "license":"MIT", "type": "theme-autoload", "require": { "php": ">=5.4.0" } } 

Entonces, si lanzo la "actualización del compositor" desde la raíz, este es el post de error.

Sus requisitos no se pudieron resolver en un set de packages instalable.

Problema 1

  • Solicitud de installation para el tema / website 2.0.4 -> satisfiable por tema / website [2.0.4].

  • el tema / website 2.0.4 requiere myframework 2.1.3 -> no se ha encontrado ningún package coincidente.

Causas potenciales:

  • Un error tipográfico en el nombre del package

  • El package no está disponible en una versión lo suficientemente estable de acuerdo con su configuration de estabilidad mínima, consulte https://getcomposer.org/doc/04-schema.md#minimum-stability para get más detalles.

Pero si hago "actualización del compositor" directamente en la ruta del tema, todo funciona bien (pone los proyectos al proveedor en lugar de la carga automática del tema, ¡pero al less funciona!)

Alguien puede ayudarme por favor? Gracias