-bash: find_git_branch: command no encontrado

Esto debería ser muy simple. Hace poco noté que cuando escribo algo en Terminal on Mac esto muestra esto:

-bash: find_git_branch: command not found bogon:git monty$ ls 1.txt index.html -bash: find_git_branch: command not found bogon:git monty$ touch 2.txt -bash: find_git_branch: command not found bogon:git monty$ ls 1.txt 2.txt index.html -bash: find_git_branch: command not found 

Cuando antes no lo hacía. ¿Alguien puede explicar por qué y cómo resolverlo?

El problema es que los mantenedores de git solo admiten MaxOS10.9 (inconformistas). Si tiene una versión anterior, no puede usar su distribución.

Recomendado por otra persona en el trabajo: use brebaje (casero). Básicamente con brew instalado puedes simplemente usar:

 brew install git 

y te dará una versión actualizada. Posteriormente para get una nueva versión, use:

brew actualizar git

Ahora brew usa git, por lo que podría ser que esta installation sea recursiva; tuve que instalarla recientemente para otro propósito y me tomó varias horas, pero una vez que la tenga allí, todo debería estar bien. Todo lo que puedo decir es que cuando instalé brew originalmente, "git" todavía se refería a la versión 1.8.x de Apple, y con este cambio ahora estoy obteniendo git v2.1.0.